Some Problems Fixed

Discussion in 'Interior/Electronics' started by TRUCK ACTION, Sep 17, 2016.

  1. TRUCK ACTION

    TRUCK ACTION Grand Toyotaholic

    Joined:
    Jan 5, 2008
    Messages:
    3,303
    Likes Received:
    121
    Location:
    Vallejo,Ca.
    Truck:
    88 Extracab,2wd
    Rolling into last weeks show the temp gauge was going up,found that when I turned the electric fan on it didn't come on, then found damage at the power distribution block in the cab over the battery. There was a lose wire to the fan controller that caused the readout panel & a fuse holder to burn!
    Got a replacement block & all is good with that problem!!

    And then there was the squealing drive belt that has been for way too long, when I ordered the alternator I had a smaller pulley made as I have under drive pulleys , the belt was riding at the bottom = the noise. Changed out pulley from a 2 3/16'' to a 2 11/16'' with corrected grove! Problem fixed!!
    1.JPG 2.JPG 3.JPG 4.JPG
     
  2. Litneon

    Litneon Super Moderator Staff Member

    Joined:
    Mar 29, 2007
    Messages:
    2,412
    Likes Received:
    42
    Location:
    Cocoa, FL
    Truck:
    94 xtra cab
    Geesh! That could have been way worse in the end. Glad you caught it.
     
  3. Orlando Muniz

    Orlando Muniz Enthusiast

    Joined:
    Jul 14, 2016
    Messages:
    270
    Likes Received:
    38
    Location:
    Pflugerville, TX was Sac Town, CA
    Truck:
    89 Toyota Pickup
    yea that could have been bad!
     
  4. TRUCK ACTION

    TRUCK ACTION Grand Toyotaholic

    Joined:
    Jan 5, 2008
    Messages:
    3,303
    Likes Received:
    121
    Location:
    Vallejo,Ca.
    Truck:
    88 Extracab,2wd
    All is fused & the fuse did pop after getting hot enough to burn the read out !
     

Share This Page