delete

Discussion in 'Maintenance/Repair' started by 1978sr5longbed, Feb 5, 2016.

  1. 1978sr5longbed

    1978sr5longbed Newbie

    Joined:
    Feb 2, 2016
    Messages:
    7
    Likes Received:
    0
    So this happen just a couple days ago my truck started running rough feels like it wants to turn off engine shakes a lot what could this be???
     
  2. fred heath

    fred heath Enthusiast

    Joined:
    Dec 29, 2011
    Messages:
    293
    Likes Received:
    47
    Location:
    Raleigh, NC
    Truck:
    1978 Toyota Galavan Motorhome.
    Bad Gas ?
    Go back to when problem first started. Did you do any maintenance just before?
    Difficult to diagnose by your description.
     
  3. 1978sr5longbed

    1978sr5longbed Newbie

    Joined:
    Feb 2, 2016
    Messages:
    7
    Likes Received:
    0
    It feels like it needs a tune up
     
  4. jetas

    jetas Grand Toyotaholic

    Joined:
    Mar 26, 2009
    Messages:
    4,964
    Likes Received:
    383
    Location:
    Oxnard, CA
    Truck:
    72.5 Hilux
    Idle too low, bad gas, crappy grounds, driveshaft oil is possibly low. Need more details.
     
  5. 1978sr5longbed

    1978sr5longbed Newbie

    Joined:
    Feb 2, 2016
    Messages:
    7
    Likes Received:
    0
    When I start the truck the motor shakes alot like if its not gettin enough air I did a tune up and still didnt fix the problem idk how else to explain it the truck stays on it just runs like crap
     
  6. YOguyDA

    YOguyDA Addict

    Joined:
    Jun 20, 2009
    Messages:
    731
    Likes Received:
    57
    Location:
    Sacramento, CA
    Truck:
    1986 Regular Cab
    When you bring up the rpm's, does it run smooth?
     
  7. 1978sr5longbed

    1978sr5longbed Newbie

    Joined:
    Feb 2, 2016
    Messages:
    7
    Likes Received:
    0
    yes when i give it gas it runs smooth
     
  8. 1978sr5longbed

    1978sr5longbed Newbie

    Joined:
    Feb 2, 2016
    Messages:
    7
    Likes Received:
    0
    i did the tune up like spark plugs cap and rotor....i don't know what else to do...is it a air leak?...bad carb??...when i drive on the freeway it runs great....red lights or just letting it idle it running very rough like if the engine is struggling to stay on...i hope this is enough info i don't know how else to explain it
     
  9. fred heath

    fred heath Enthusiast

    Joined:
    Dec 29, 2011
    Messages:
    293
    Likes Received:
    47
    Location:
    Raleigh, NC
    Truck:
    1978 Toyota Galavan Motorhome.

    Check all your vacuum lines running from the carb. These tend to dry out and become brittle.
    Find a vacuum gage somewhere and attach to a "manifold vacuum" source. Not a "ported" source.
    The gage should give you a good idea where the problem might be. It sounds like you have a vacuum leak somewhere.
    Did you change the gas filter with tune up?
     
  10. 1978sr5longbed

    1978sr5longbed Newbie

    Joined:
    Feb 2, 2016
    Messages:
    7
    Likes Received:
    0
    hey thank u for your help....but yesterday i got so tired of the problem i took off the air filter and the air filter assembly and saw that the choke was stuck open and also took off egr and cleaned it the truck runs great now
     
  11. fred heath

    fred heath Enthusiast

    Joined:
    Dec 29, 2011
    Messages:
    293
    Likes Received:
    47
    Location:
    Raleigh, NC
    Truck:
    1978 Toyota Galavan Motorhome.
    Glad to hear it. These trucks are old, but so much fun to work on.
     
  12. TRUCK ACTION

    TRUCK ACTION Grand Toyotaholic

    Joined:
    Jan 5, 2008
    Messages:
    3,691
    Likes Received:
    219
    Location:
    Vallejo,Ca.
    Truck:
    88 Extracab,2wd
    CHECK THE FIRING ORDER,SOUNDS LIKE A PLUG WIRE IS OUT OF PLACE ,IF YOU HAD JUST CHANGED
    THEM!!
     

Share This Page