Turn Signals wont work

Discussion in 'Maintenance/Repair' started by seeairuhx3, Mar 31, 2011.

  1. seeairuhx3

    seeairuhx3 Newbie

    Joined:
    Mar 31, 2011
    Messages:
    4
    Likes Received:
    0
    Location:
    Ohio
    Truck:
    '91 Pickup
    Okay. This happened all weird and random. First my left tail light went out, but brake light works. I changed the bulbs. replaced the housing from my other toyota to it, still nothing. then my right rear turn signal stopped working. did the same thing. checked everything. now my left front turn signal doesn't work. i checked fuses, i checked every light. i dont know why or how it just randomly happened but i feel like a driving hazard right now. anyone know anything about this?
     
  2. eurofreak2002

    eurofreak2002 Toyotaholic

    Joined:
    Jul 26, 2010
    Messages:
    1,980
    Likes Received:
    0
    Location:
    B-town 208
    Truck:
    80 STD SR5 LB, bagged! The new whip!
    Well in another thread you mentioned something about tearing the dash apart? I dont know if this was recently or If your in progress of doing such but sometimes if the connector for your hazard lights is not plugged in this will cause loss of turn signals. However it sound more like they have just all started randomly quiting on you at different times so maybe one of the relays has a short.
     
  3. DionTDE

    DionTDE Addict

    Joined:
    Dec 21, 2010
    Messages:
    997
    Likes Received:
    1
    Location:
    Preston, ID
    Truck:
    93 single cab 2wd
    Yes the hazard switch was not connected on my dash and it gave me quite a hard time. I did get it fixed and ran into a few other issues you might want to check. I noticed the connector for the front bumper turn signals can be misleading. I have the polarity backwards on one of mine but it looked right to me.
    I also noticed the bumper light connectors can lose its "spring" for the connecting points to the bulb.
    Let me know if this helps or not. If it doesnt I could give you more info. I torn my entire turn signal setup apart to find the issue.
     
  4. junk_jivin38

    junk_jivin38 Member

    Joined:
    Sep 26, 2010
    Messages:
    69
    Likes Received:
    0
    Location:
    NY
    Truck:
    84 longbed 22R
    My rears went out intermittently...even got a ticket after i thought i fixed it...eliminated a couple connectors behind rear bumper and spliced in new wire...also found a wire crossing the bumper bracket that had chafed and grounded out....no problems since
     

Share This Page